Apache HTTP 2.4.27 + mod_http2 1.10.12 パッケージの配布

さくっとインストールできるように Scientific Linux 7 と CentOS 7 用の Apache HTTP Server rpm パッケージを用意しました。 Apache のバージョンは 2.4.27 ですけど脆弱性(CVE-2017-9798)は対策済(2.4.28よりバックポート済)です。もちろん HTTP/2 も対応済です。

ダウンロード

【 apr-1.6.2 】と Apache は【 yk3 】をダウンロードしてください。

配布パッケージの説明

新規インストールすると Apache が event で動作します。(アップデートインストールの場合は【 /etc/httpd/conf.modules.d/00-mpm.conf 】を確認してください)


# cat /etc/httpd/conf.modules.d/00-mpm.conf
# Select the MPM module which should be used by uncommenting exactly
# one of the following LoadModule lines:

# prefork MPM: Implements a non-threaded, pre-forking web server
# See: http://httpd.apache.org/docs/2.4/mod/prefork.html
#LoadModule mpm_prefork_module modules/mod_mpm_prefork.so

# worker MPM: Multi-Processing Module implementing a hybrid
# multi-threaded multi-process web server
# See: http://httpd.apache.org/docs/2.4/mod/worker.html
#
#LoadModule mpm_worker_module modules/mod_mpm_worker.so

# event MPM: A variant of the worker MPM with the goal of consuming
# threads only for connections with active processing
# See: http://httpd.apache.org/docs/2.4/mod/event.html
#
LoadModule mpm_event_module modules/mod_mpm_event.so

MPM が prefork 動作の時は HTTP/2 が無効になりますので気をつけてください。


# httpd -V|grep MPM
Server MPM:     event

シェアする

コメント

トラックバック

トラックバック用URL
http://www.youyoukankan.net/cms/action.php?action=plugin&name=TrackBack&tb_id=199
トラックバック
このエントリにトラックバックはありません